Про образы

Просмотр 15 сообщений - с 16 по 30 (из 87 всего)
  • Автор
    Сообщения
  • #903
    theriodont
    Участник
    @theriodont

    Странно, у меня и самба из командной строки без проблем встала, и общие папки сразу появились. Видимо все же проблемы с переносимостью.

    #906
    admin
    Хранитель
    @admin

    Дайте ссылку на дистрибутив, который Вы использовали.

    #909
    theriodont
    Участник
    @theriodont

    Дистрибутив линукса здесь:
    https://www.linuxmint.com/download_lmde.php

    Если про самбу, то просто ввести в командной строке “sudo apt install samba”, на запрос пароля ввести пароль админа, на вопрос “продолжить?” ответить “y”, все зависимости должны загрузиться автоматически.

    Если общие папки подключатся, они отобразятся на рабочем столе, но с рабочего стола внутрь не пускают, нужно открыть “Мой компьютер”, и оттуда уже заходить с паролем.

    #912
    theriodont
    Участник
    @theriodont

    В самом VB еще проверьте, что Extension Pack установился правильно (Файл -> настройки -> плагины, в списке должен быть Oracle VM VirtualBox Extension Pack), без него общие папки работать не будут.

    #915
    admin
    Хранитель
    @admin

    Ext pack стоит. Вот попытка поставить самбу на свежеустановленную в VB систему:
    mike@lmde:~$ sudo apt install samba
    [sudo] пароль для mike:
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Пакет samba недоступен, но упомянут в списке зависимостей другого пакета.
    Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
    Однако следующие пакеты могут его заменить:
    samba-common samba-libs

    E: Для пакета «samba» не найден кандидат на установку
    mike@lmde:~$

    #919
    theriodont
    Участник
    @theriodont

    Чет дичь какая-то, я никаких источников у себя не добавлял. Попробуйте обновить линукс – значок внизу на трее справа, или в терминале sudo apt update, затем sudo apt upgrade.

    #922
    theriodont
    Участник
    @theriodont

    Вот кстати нашел в сети по поводу такой же проблемы:

    Сохраните и выполните следующую команду:

    sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade sudo apt-get install samba

    -get сейчас можно не набирать.

    #927
    admin
    Хранитель
    @admin

    Сделал, как Вы писали в предпоследнем сообщении. Теперь так и непонятно, встала она или нет? Как ее запустить?
    mike@lmde:~$ sudo apt install samba
    [sudo] пароль для mike:
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Будут установлены следующие дополнительные пакеты:
    python-dnspython tdb-tools
    Предлагаемые пакеты:
    bind9 bind9utils ctdb ldb-tools ntp | chrony smbldap-tools winbind
    Рекомендуемые пакеты:
    attr samba-dsdb-modules samba-vfs-modules
    НОВЫЕ пакеты, которые будут установлены:
    python-dnspython samba tdb-tools
    обновлено 0, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
    Необходимо скачать 1 080 kB/1 107 kB архивов.
    После данной операции, объём занятого дискового пространства возрастёт на 12,0 MB.
    Хотите продолжить? [Д/н] y
    Пол:1 http://security.debian.org stretch/updates/main i386 samba i386 2:4.5.16+dfsg-1+deb9u2 [978 kB]
    Пол:2 http://deb.debian.org/debian stretch/main i386 python-dnspython all 1.15.0-1+deb9u1 [102 kB]
    Получено 1 080 kБ за 0с (1 360 kБ/c)
    Выбор ранее не выбранного пакета python-dnspython.
    (Чтение базы данных … на данный момент установлено 251540 файлов и каталогов.)
    Подготовка к распаковке …/python-dnspython_1.15.0-1+deb9u1_all.deb …
    Распаковывается python-dnspython (1.15.0-1+deb9u1) …
    Выбор ранее не выбранного пакета tdb-tools.
    Подготовка к распаковке …/tdb-tools_1.3.11-2_i386.deb …
    Распаковывается tdb-tools (1.3.11-2) …
    Выбор ранее не выбранного пакета samba.
    Подготовка к распаковке …/samba_2%3a4.5.16+dfsg-1+deb9u2_i386.deb …
    Распаковывается samba (2:4.5.16+dfsg-1+deb9u2) …
    Настраивается пакет python-dnspython (1.15.0-1+deb9u1) …
    Обрабатываются триггеры для ufw (0.35-4) …
    Обрабатываются триггеры для libc-bin (2.24-11+deb9u4) …
    Обрабатываются триггеры для systemd (232-25+deb9u11) …
    Настраивается пакет tdb-tools (1.3.11-2) …
    update-alternatives: используется /usr/bin/tdbbackup.tdbtools для предоставления /usr/bin/tdbbackup (tdbbackup) в автоматическом режиме
    Обрабатываются триггеры для man-db (2.7.6.1-2) …
    Настраивается пакет samba (2:4.5.16+dfsg-1+deb9u2) …
    Добавляется группа «sambashare» (GID 127) …
    Готово.
    Samba is not being run as an AD Domain Controller, masking samba-ad-dc-service.
    Please ignore the following error about deb-systemd-helper not finding samba-ad-dc-service.
    Created symlink /etc/systemd/system/multi-user.target.wants/nmbd.service → /lib/systemd/system/nmbd.service.
    Failed to preset unit: Unit file /etc/systemd/system/samba-ad-dc.service is masked.
    /usr/bin/deb-systemd-helper: error: systemctl preset failed on samba-ad-dc.service: No such file or directory
    Created symlink /etc/systemd/system/multi-user.target.wants/smbd.service → /lib/systemd/system/smbd.service.
    Обрабатываются триггеры для libc-bin (2.24-11+deb9u4) …
    Обрабатываются триггеры для systemd (232-25+deb9u11) …
    Обрабатываются триггеры для ufw (0.35-4) …
    mike@lmde:~$

    #930
    admin
    Хранитель
    @admin

    А вот по последнему сообщению:
    mike@lmde:~$ sudo apt update && sudo apt upgrade && sudo apt dist-upgrade sudo apt install samba
    Сущ:1 http://www.deb-multimedia.org stretch InRelease
    Игн:2 http://deb.debian.org/debian stretch InRelease
    Сущ:3 http://security.debian.org stretch/updates InRelease
    Игн:4 http://packages.linuxmint.com cindy InRelease
    Сущ:5 http://deb.debian.org/debian stretch-updates InRelease
    Сущ:6 http://deb.debian.org/debian stretch Release
    Сущ:7 http://packages.linuxmint.com cindy Release
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Все пакеты имеют последние версии.
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Расчёт обновлений… Готово
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    E: Не удалось найти пакет install
    mike@lmde:~$

    #933
    admin
    Хранитель
    @admin

    Вроде самба стоит, но что делать дальше? Папка не видна, друг друга гость (Linux) и хост (win) не видят…

    #943
    theriodont
    Участник
    @theriodont

    В VB в настройках виртуальной машины общие папки заданы? Драйвера с iso-образа Extension Pack установлены?

    #962
    admin
    Хранитель
    @admin

    Да, все это есть

    #981
    theriodont
    Участник
    @theriodont

    Не знаю тогда. Можно переносить данные через ISO-образы или USB, или как вариант поставить второй системой.

    #984
    theriodont
    Участник
    @theriodont

    Можно еще включить двунаправленные буфер обмена и функцию Drag&Drop.

    #987
    admin
    Хранитель
    @admin

    Это включено и работает. Тут, думаю, две причины: мое незнание Linux и изменения в сети для Windows 10. Надо хороший мануал найти. А то я даже не знаю, как запустить графический редактор, пользуюсь каким-то nano. Пока я остановлюсь. В свете отсутствия в RDz компиляции под Linux, нам Linux образ нужен только для IS. Нол нужен обязательно, т.к. OS/2 уж очень древняя и ей никто не пользуется.

Просмотр 15 сообщений - с 16 по 30 (из 87 всего)
  • Для ответа в этой теме необходимо авторизоваться.
Авторизация
*
*

десять + семь =

или используйте социальную сеть:
Регистрация
*
*
*

3 × 5 =

Генерация пароля

восемь − 6 =

Перевести »
Пролистать наверх